Slow ETH receive transactions
Incident Report for Luno
Resolved
All ETH receive transactions have been processed as normal.

Thanks for your patience.
Posted May 17, 2021 - 14:07 UTC
Identified
We have identified an issue with slow ETH receive transactions. While a fix has been implemented we expect ETH receives to be delayed.

Updates to follow.
Posted May 17, 2021 - 13:25 UTC
This incident affected: Crypto sends and receives (ETH).