All transactions(buy, sell, send, receive) related to MATIC have been suspended as it is currently going through rebranding to POL. We are currently working on this issue and we apologise for the inconvenienced caused.
Posted Jul 08, 2025 - 07:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 07:29 UTC
Investigating
All transactions(buy, sell, send, receive) related to MATIC have been suspended as it is currently going through rebranding. We are currently working on this issue and we apologise for the inconvenienced caused.