Customers who use FNB may be unable to add new accounts via Stitch in South Africa
Incident Report for Luno
Resolved
Update:

The issue preventing FNB customers from linking new bank accounts via Stitch has been resolved.

Thank you for your patience.
Posted Nov 10, 2024 - 16:06 UTC
Update
We have identified an issue preventing South African customers from linking new FNB bank accounts to their Luno accounts.

Unfortunately, this is an issue with our third-party banking partner.

We are working with them to try and get this resolved.

In the meantime, please make use of an alternative deposit method in your Luno wallet such as EFT/Bank transfers.
Posted Nov 10, 2024 - 10:39 UTC
Identified
We have identified an issue preventing South African customers from linking new FNB bank accounts to their Luno accounts.

Unfortunately, this is an issue with our third-party banking partner.

In the meantime, please make use of an alternative deposit method in your Luno wallet.

Updates to follow.
Posted Nov 10, 2024 - 10:39 UTC