Delayed withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are now being processed as normal. All pending transactions have been cleared.

We apologise for any inconvenience this may have caused and appreciate your patience.
Posted Jul 29, 2024 - 08:59 UTC
Monitoring
Withdrawals are now being processed as normal. We will continue to monitor the situation for any further delays.
Posted Jul 29, 2024 - 06:40 UTC
Identified
Withdrawals to FNB, ABSA, and Capitec in South Africa are currently delayed. Please note that due to banking hours over the weekend, these delays may be longer than usual.

We’re working to address the issue and appreciate your patience.
Posted Jul 27, 2024 - 07:45 UTC