We are continuing to work closely with our third-party provider, who is still investigating the underlying cause. At this time, the issue is not impacting verifications. We will continue to monitor and share any relevant updates as needed.
Thank you for your patience and understanding.
Posted Aug 04, 2025 - 14:04 UTC
Update
We are working closely with our third-party provider, who is continuing to investigate the BVN verification issue. We understand the importance of resolving this and will provide further updates as soon as we have more information.
Thank you for your continued patience.
Posted Aug 01, 2025 - 14:29 UTC
Identified
We have identified an issue that may prevent customers from verifying their BVN number, even after they've received the verification email. Our team is actively working with our third-party provider to resolve this as quickly as possible.