Intermittent Slow Bitcoin Sends
Incident Report for Luno
Resolved
This issue has been resolved, Bitcoin send transactions have returned to normal.

Thank you for your patience in this regard.
Posted May 18, 2023 - 06:56 UTC
Update
This issue has been resolved, Bitcoin send transactions have returned to normal.

Thank you for your patience in this regard.
Posted May 18, 2023 - 06:56 UTC
Update
We've identified an issue causing intermittent delays for some Bitcoin send transactions. This may result in slower than usual send times for some customers. Our team is aware of the delay and is working on a fix.

Receiving Bitcoin to your Luno wallet remains unaffected.

Updates to follow soon.
Posted May 17, 2023 - 14:21 UTC
Identified
We've identified an issue casusing intermittant dealys for some Bitcoin send transactions. This may result in slower than usual send times for some customers. Our team is aware of the delay and is working on a fix.

Receiving Bitcoin to your Luno wallet remains unaffected.

Updates to follow soon.
Posted May 17, 2023 - 09:27 UTC