Delayed deposits in Nigeria
Incident Report for Luno
Resolved
A fix has been implemented and there are no longer delayed deposits via bank transfers.

We appreciate your patience and understanding in this matter.
Posted Jan 06, 2025 - 07:16 UTC
Identified
Customers may experience delays with deposits via bank transfer.

Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.

We appreciate your understanding and apologise for any inconvenience this may cause.
Posted Jan 06, 2025 - 06:27 UTC