Sends are delayed for USDT

Incident Report for Luno

Resolved

Update:

We are no longer seeing any delays for USDT.

USDT send processing has returned to normal.

We appreciate your patience and understanding in this matter.
Posted Jun 23, 2026 - 08:24 UTC

Identified

We have identified an issue affecting sends for USDT.

Some customers may experience longer than usual processing times when attempting to send USDT cryptocurrency.

Our team is working on this as a priority.
Posted Jun 23, 2026 - 00:42 UTC