Delayed deposits and withdrawals
Incident Report for Luno
Resolved
The issue has been resolved. Deposits and withdrawals are working as usual.
Posted Jul 15, 2021 - 16:24 UTC
Identified
Some customers may experience a delay in their deposits and withdrawal.

Our team is aware of the delay and is working on a fix as a priority.
Posted Jul 15, 2021 - 15:40 UTC