Delayed sends
Incident Report for Luno
Resolved
This issue has been resolved and all sends are being processed as normal.
Posted Oct 24, 2022 - 08:05 UTC
Investigating
We are currently investigating an issue causing delayed sends for some customers, receives remain unaffected.
Posted Oct 24, 2022 - 01:01 UTC