Delayed Ethereum sends and receives
Incident Report for
Luno
Resolved
This incident has been resolved. There are no more delays experienced when sending or receiving Ethereum from your Luno wallet
Posted
Sep
09
,
2022
-
11:41
UTC
Monitoring
A fix has been implemented and ETH send and receive transaction times have returned to normal. We'll continue to monitor closely.
Posted
Sep
09
,
2022
-
00:32
UTC
Investigating
You may experience a delay when sending or receiving Ethereum from your Luno wallet. Our team is currently looking into this. Updates to follow.
Posted
Sep
08
,
2022
-
23:31
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Ethereum sends and receives
via . You'll receive .