Delayed Deposits and Withdrawals in South Africa
Incident Report for
Luno
Resolved
This has been resolved.
There are no further delays to deposits and withdrawals, thanks again for your patience.
Posted
Mar
15
,
2024
-
16:39
UTC
Monitoring
Deposits and withdrawals are now being processed as normal.
We will continue to monitor for any further issues.
Thanks for your patience and apologies for the inconvenience caused.
Posted
Mar
15
,
2024
-
16:04
UTC
Identified
We are aware of an issue that is causing delays with our deposits and withdrawals for customers in South Africa. We are working on this as a priority.
We apologise for the inconvenience caused and appreciate your patience.
Posted
Mar
15
,
2024
-
07:35
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Deposits and Withdrawals in South Africa
via . You'll receive .