Slow BCH receives
Incident Report for Luno
Resolved
This has been resolved, thanks for your patience.
Posted Aug 25, 2021 - 13:25 UTC
Monitoring
Impact of this issue has been determined as fairly small, only affected a handful of customers. We're hoping to see this resolved soon, thanks for your patience.
Posted Aug 25, 2021 - 11:14 UTC
Identified
We've identified an issue affected some BCH receive transactions to Luno wallets, we're working on a fix.
Posted Aug 25, 2021 - 10:40 UTC