Delayed ATOM Rewards Payout
Incident Report for
Luno
Resolved
The issue has been resolved, rewards are being paid out for customers.
Posted
Nov
12
,
2025
-
13:59
UTC
Monitoring
Rewards are now being paid out to customers. We will monitor for any issues.
Thank you for your patience.
Posted
Nov
12
,
2025
-
06:39
UTC
Identified
Customers who have staked ATOM will experience delays in their rewards payout.
We are working to fix the issue as a priority and we apologise for the inconvenienced caused.
Posted
Nov
11
,
2025
-
14:10
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed ATOM Rewards Payout
via . You'll receive .