Delayed TRX sends
Incident Report for
Luno
Resolved
All delayed TRX transactions have been successfully processed and everything is now back to normal.
Thank you for your patience.
Posted
Jun
11
,
2025
-
15:00
UTC
Monitoring
We are now seeing TRX transactions being processed for previously delayed sends. Transactions are being successfully completed.
We will continue to monitor the situation closely.
Posted
Jun
11
,
2025
-
13:04
UTC
Identified
We have identified an issue causing a delay in TRX sends.
Our team is actively working to resolve this as a priority, and we hope to have it addressed soon.
Posted
Jun
11
,
2025
-
09:40
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed TRX sends
via . You'll receive .