Slow bank deposits in Europe
Incident Report for Luno
Resolved
Deposits are being processed as normal, thanks for your patience.
Posted Aug 02, 2021 - 16:46 UTC
Update
We're working closely with our bank to see deposit times return to normal.
Posted Aug 02, 2021 - 14:01 UTC
Identified
Deposits to Luno's bank account may take longer than usual to clear in your Luno wallet, this currently affects customers in GB and EU. Our team are aware of the issue and are working on a fix.
Posted Aug 02, 2021 - 09:53 UTC