Instant Buy/Sell Errors Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 25, 2021 - 07:47 UTC
Identified
We are aware of an issue that is occurring with our instant buy/sell function and are working hard to get the issue resolved as soon as possible
Posted May 24, 2021 - 12:01 UTC