Delayed bank deposits and withdrawals in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.

Thank you for your patience.
Posted Mar 10, 2023 - 07:19 UTC
Investigating
We are currently experiencing an issue that may be causing temporary delays with deposit and withdrawal voucher redemption. We are working to get this resolved as soon as possible.

We apologise for any inconvenience.
Posted Mar 09, 2023 - 15:59 UTC