DOT reduced reward and staking delays

Incident Report for Luno

Update

Update: Staking rewards have returned back to expected reward levels as the Polkadot chain migration voting has concluded. We are still currently working on the staking delays issue and will provide further updates as soon as it is resolved. We thank you for your continued patience.
Posted Nov 13, 2025 - 08:36 UTC

Update

We have identified the issue with DOT staking and are currently working on resolving it as soon as possible. More updates to follow. Thank you for your continued patience.
Posted Nov 10, 2025 - 10:41 UTC

Identified

DOT staking is currently experiencing delays and reduced rewards due to a Polkadot chain migration. We are monitoring the situation and will update once normal operations resume.
Posted Nov 07, 2025 - 12:09 UTC