Intermittent incorrect wallet balance
Incident Report for
Luno
Resolved
Update:
We are no longer seeing any issues with wallet balances.
We appreciate your understanding in this matter.
Posted
Sep
21
,
2025
-
09:05
UTC
Identified
We have identified an issue that may cause some customers to see their Luno wallet balance as zero intermittently.
Our team is investigating this issue as a priority, but we want to assure our customers that all their funds are secure.
Updates to follow.
Posted
Sep
19
,
2025
-
13:50
UTC
×
Subscribe to Incident
Subscribe to updates for
Intermittent incorrect wallet balance
via . You'll receive .