Delayed Withdrawals In Indonesia

Incident Report for Luno

Resolved

The issue has now been resolved. Thank you for your patience.
Posted Apr 21, 2026 - 07:06 UTC

Identified

Customers are currently experiencing withdrawal delays due to an issue with one of our third-party providers. Resolving this is our top priority, and we are working closely with them to implement a fix.

We sincerely apologise for the inconvenience.
Posted Apr 20, 2026 - 08:52 UTC