Slow Bank Deposits and Withdrawals in South Africa
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 13, 2021 - 07:35 UTC
Update
We are still working with the bank to resolve the technical issues being experienced. To reduce any delays with deposits, please use an alternative deposit option. Withdrawals are still being processed as normal, however the status may still show as pending on your Luno account.
Posted May 04, 2021 - 11:07 UTC
Investigating
We're aware of a technical issue with deposits to our Standard Bank account and our team is currently investigating it. We hope to have this resolved soon. In the meantime, please make use of an alternative deposit method in your Luno wallet. Withdrawals are still processing, but the status will not update. You can continue to request withdrawals
Posted Apr 22, 2021 - 16:50 UTC