Delayed send and recieves for ETH

Incident Report for Luno

Resolved

ETH sends and receives have fully returned to normal. The issue has been resolved, and no further impact is expected.
Posted Dec 08, 2025 - 11:50 UTC

Update

ETH sends and receives are still being processed, however we're seeing some further delays. We have recently deployed a fix for this issue and are actively monitoring it. More updates to follow.
Posted Dec 06, 2025 - 14:01 UTC

Monitoring

ETH sends and receives are back to normal. We will continue to monitor the situation for any further delays.
Posted Dec 06, 2025 - 07:48 UTC

Identified

ETH sends are currently being processed, but with delays. We have identified the cause and are actively working on a fix.
Posted Dec 04, 2025 - 16:55 UTC

Investigating

We are currently investigating an issue that may be causing customers to experience delays when sending or receiving ETH.

We are working on this as a matter of priority and will provide updates as soon as they become available.
Posted Dec 04, 2025 - 14:24 UTC