Exchange Balance update delays

Incident Report for Luno

Resolved

Update:

We are no longer seeing delays in balance updates for customers who use the exchange.

We appreciate your patience and understanding in this matter.
Posted Sep 11, 2026 - 14:29 UTC

Identified

Customers using the exchange and executing trades may see delays with their balance updates, which may cause customers who perform high-volume trading to experience disruptions with their trading due to the delays to balance updates.

Customers who use Instant Buy and Sell will not be affected.

We are working on this as a priority.
Posted Sep 11, 2026 - 13:24 UTC