Delayed Deposits And Withdrawals in Nigeria

Incident Report for Luno

Resolved

The issue affecting deposits and withdrawals has been resolved, and all services are operating normally.

We appreciate your patience and understanding while we worked to resolve this matter.
Posted Jun 20, 2026 - 05:48 UTC

Monitoring

We are no longer seeing any delays with deposits and withdrawals, and services appear to be operating as expected. We will continue to monitor the situation closely to ensure stability.
Posted Jun 19, 2026 - 18:50 UTC

Identified

We have identified an issue currently causing delays with deposits and withdrawals for our Nigerian customers.

Unfortunately, this issue is on our payment providers' side; we are working with them to try to solve this as quickly as possible.

We appreciate your understanding in this matter.
Posted Jun 19, 2026 - 17:21 UTC