No further delays since our last update, apologies again for any issues this has caused.
Posted Oct 06, 2025 - 08:11 UTC
Monitoring
A fix has been implemented for the issue that was causing delays in crypto withdrawals, and all withdrawals are now processing normally. We will continue to monitor for any further issues.
Posted Oct 06, 2025 - 05:11 UTC
Identified
We have identified an issue causing delays in crypto withdrawals. Our team is actively monitoring the situation and working to get this resolved as soon as possible.