The issue has been resolved. Thank you for your patience
Posted Mar 24, 2026 - 06:18 UTC
Monitoring
A fix has been implemented on the new version, we are monitoring.
Thank you for your patience.
Posted Mar 23, 2026 - 06:54 UTC
Update
We are still testing the fix for this issue and are working on it as a priority. Once the fix has been tested it will then be deployed to the App store for review.
For awareness, customers can still buy USDC via the web page
We apologise for any inconvenience caused and thank you for your patience.
Posted Mar 20, 2026 - 14:09 UTC
Update
We are currently testing the fix for this issue.
We apologise for any inconvenience caused and we are working on this as a priority.
Posted Mar 18, 2026 - 08:28 UTC
Identified
Customers using IOS are unable to buy USDC via PayU.
Customers can still buy USDC via the Web page. We are working to fix this issue as a priority