Customers unable to complete the Buy flow on Android in the UK
Incident Report for Luno
Resolved
No further issues have been reported and the instant buy flow is working as expected for UK customers.

We apologise for the inconvenience this may have caused and thank you for your patience.
Posted Jul 26, 2024 - 14:53 UTC
Monitoring
A fix has been applied, we ask customers on Android in the UK to please update their app to version 8.63.3 or above.
Thanks again for your patience.
Posted Jul 24, 2024 - 13:06 UTC
Identified
We've identified an issue affecting some customers in the UK going through the Instant Buy Flow, our team are prioritising a fix which will be submitted to the Play Store.

An update will be provided on our status page, customers can make use of Web as a work around.

Apologies for the inconvenience.
Posted Jul 24, 2024 - 11:05 UTC