Error during verification for new customers
Incident Report for Luno
Resolved
We are seeing no further issues with the verification process for new customers.

We apologise for any inconvenience caused
Posted May 11, 2023 - 18:38 UTC
Monitoring
We have implemented a fix for the verification issues and customers should be able to progress successfully through the verification process.

We are monitoring to make sure there are no further issues.
Posted May 11, 2023 - 18:36 UTC
Investigating
We are currently investigating an issue where customers are unable to complete verification. Some customers may be seeing a blank screen during this process.

We are looking into this as a matter of priority and we will provide updates as soon as they become available.
Posted May 11, 2023 - 17:42 UTC