Delayed withdrawals
Incident Report for
Luno
Resolved
All withdrawals have been processed as normal as of 09:52 UTC.
Thanks again for your patience.
Posted
Sep
26
,
2023
-
14:30
UTC
Monitoring
A fix has been implemented for this issue. We are seeing withdrawals processing as normal.
Posted
Sep
26
,
2023
-
09:52
UTC
Investigating
We are currently investigating an issue that is causing withdrawals to be delayed or fail.
We are looking into this as a matter of priority and will provide updates as soon as they become available.
Posted
Sep
26
,
2023
-
09:43
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals
via . You'll receive .