SUI Unavailable for Purchase via Instant Buy and Sell

Incident Report for Luno

Resolved

The issue has been resolved. Customers can now purchase SUI via instant buy and sell.

Thank you for your patience and understanding in this matter.
Posted Jul 27, 2025 - 09:51 UTC

Identified

Customers are currently unable to purchase SUI via Instant Buy and Sell. Our team has identified the issue and is actively working on a fix.

Customers can still purchase SUI using the Luno exchange.
Posted Jul 26, 2025 - 20:33 UTC