Deposit and Buy will be unavailable for Capitec customers in South Africa
Incident Report for Luno
Resolved
The Capitec scheduled maintenance between 13:00 on Saturday, 29 April 2023 and 01:00 on Monday, 1 May 2023 was successfully completed all services have returned to normal.
Posted May 02, 2023 - 11:57 UTC
Identified
Capitec is undergoing scheduled maintenance between 13:00 on Saturday, 29 April 2023 and 01:00 on Monday, 1 May 2023.
During this time customers using Capitec will be unable to deposit into their ZAR wallet as well as use Instant Buy with their credit cards.
Posted Apr 28, 2023 - 09:03 UTC