Delayed sends for XRP and USDC
Incident Report for Luno
Resolved
The issue causing customers USDC and XRP sends to be delayed has been resolved.
Sends are being processed as normal.


Thank you for your patience in this regard.
Posted Mar 15, 2023 - 10:03 UTC
Investigating
We are currently investigating an issue where customers may be experiencing delays in sending XRP and USDC.

We are looking at this as a matter of priority.
Posted Mar 15, 2023 - 07:19 UTC