Delayed direct deposits in Malaysia
Incident Report for Luno
Resolved
Direct deposits in Malaysia seem to be processing accordingly.

We apologise for any inconvenience caused.
Posted Apr 27, 2024 - 05:04 UTC
Investigating
We are investigating an issue that may cause direct deposits in Malaysia to be delayed.
Posted Apr 27, 2024 - 04:38 UTC