Delayed deposits via Checkout Cards Europe
Incident Report for
Luno
Resolved
We have confirmed this has been resolved and deposits are being processed as normal.
Posted
Dec
01
,
2023
-
11:26
UTC
Monitoring
A fix has been implemented for the issues causing delays for customers attempting to deposit via Checkout Cards EUR/GBP
We are continuing to monitor closely to ensure no further issues.
Posted
Nov
30
,
2023
-
09:26
UTC
Investigating
We have identified an issue that is causing delays for customers attempting to deposit via Checkout Cards EUR/GBP
We are looking into this as a matter of priority.
Posted
Nov
30
,
2023
-
08:20
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed deposits via Checkout Cards Europe
via . You'll receive .