Delayed Deposits in Nigeria
Incident Report for
Luno
Resolved
Deposits should be working as normal with no errors or delays.
We appreciate your understanding in this matter.
Posted
Jul
03
,
2025
-
06:27
UTC
Identified
We have identified an issue currently causing delays with deposits.
Unfortunately, this issue is on our payment providers' side, we are working with them to try and solve this as quickly as possible.
We appreciate your understanding in this matter.
Updates to follow.
Posted
Jul
02
,
2025
-
18:44
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Deposits in Nigeria
via . You'll receive .