Luno exchange errors
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 07:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2020 - 12:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 01, 2020 - 12:45 UTC
Investigating
We are currently investigating an issue that is affecting our Exchange.

Our team are investigating urgently, updates to follow.
Posted Jun 01, 2020 - 12:37 UTC