Public Holiday Reminder - Withdrawal Request will take longer than usual in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted May 05, 2023 - 00:44 UTC
Identified
The 4th of May is a public holiday in Malaysia, during which banks do not process payments. This means any withdrawals from Luno that we send to the banks won’t be processed by them until the 5th of May.

Please note that this only applies to MYR withdrawals. Crypto withdrawals are being processed as normal according to our service level agreements.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 03, 2023 - 02:25 UTC