We aren't seeing any further impact, account verifications in South Africa are being processed as normal.
Posted Nov 13, 2023 - 08:26 UTC
Monitoring
A fix has been implemented, we're monitoring the results. Level 1 accounts should be verified as soon as correct information is submitted. Impacted customers would have been asked to provide additional details but may still have been successfully verified during the brief outage.
Posted Nov 13, 2023 - 08:16 UTC
Identified
Customers trying to verify their account to Level 1 may see a slower than usual turn around time, these are typically customers signing up for the first time.
Our team are working on a fix. There's no need to do anything, we'll verify all Level 1 accounts as soon as possible. Thanks for your patience.