GBP Withdrawals are delayed
Incident Report for Luno
Resolved
Issue has been resolved and no longer has any customer impact.
Posted Jan 06, 2025 - 08:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 06, 2025 - 05:37 UTC
Investigating
There is an issue that is preventing GBP and EUR withdrawals and we are currently investigating.
Posted Jan 04, 2025 - 16:15 UTC