Delayed withdrawals in Nigeria
Incident Report for
Luno
Resolved
This issue has been resolved.
Withdrawals via Bank transfer are working as expected.
We appreciate your understanding and apologize for any inconvenience this may have caused.
Posted
Apr
01
,
2025
-
09:40
UTC
Update
Update:
We have identified an issue causing withdrawal delays.
Customers may see longer than normal processing times when intialing a withdrawal via bank transfer
Unfortunately, this issue is with our payment provider, We are working closely with them to resolve this as soon as possible.
We appreciate your understanding and apologize for any inconvenience this may cause.
Posted
Mar
31
,
2025
-
20:18
UTC
Identified
We have identified an issue causing customers to experience delays in withdrawals via Bank transfer
Our team is working to solve this issue ASAP.
We appreciate your understanding and apologize for any inconvenience this may cause.
Posted
Mar
31
,
2025
-
20:06
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals in Nigeria
via . You'll receive .