Bank transfer with Flutterwave disrupted
Incident Report for Luno
Resolved
This issue with card payments via Flutterwave has been resolved.
Posted May 31, 2022 - 12:01 UTC
Identified
We are currently experiencing an issue with card payments via Flutterwave.

This service is currently unavailable.
All other deposit methods are working as expected.

We are looking into this as a matter of priority.

We apologise for any inconvenience.
Posted May 30, 2022 - 10:18 UTC