Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals have been processed as normal from our last update yesterday, 15:51 UTC on 29 December 2021.
Posted Dec 30, 2021 - 08:31 UTC
Monitoring
Withdrawals previously stuck have cleared, we're monitoring closely for any further errors.
Thanks for your patience.
Posted Dec 29, 2021 - 15:51 UTC
Investigating
We're investigating delays with bank withdrawals in South Africa, withdrawals requested today may be taking longer to get to your bank than expected.

Updates to follow soon.
Posted Dec 29, 2021 - 14:54 UTC