Persistence Of Orders And Balance are Delayed in Indonesia

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 09:41 UTC

Identified

We are seeing an delayed issue of persistent orders and balance updates. Our team is working on fixing the issue.
Posted Jul 29, 2025 - 09:01 UTC