Delayed bank withdrawal in South Africa
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled.

Thank you
Posted Jun 17, 2022 - 06:11 UTC
Investigating
Withdrawals in South Africa will not be processed on 16/06/2022 due to the public holiday, unfortunately, banks do not process withdrawals over public holidays.

Requested withdrawals will be processed on 17/06/2022

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 16, 2022 - 05:59 UTC
This incident affected: Bank deposits and withdrawals (South Africa).