Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted May 18, 2022 - 03:47 UTC
Identified
Withdrawals requested after 3.45pm on 13th May will not be processed on 16th May due to the public holiday. Unfortunately, banks do not process withdrawals over weekends and public holidays.

Requested withdrawals will be processed on 17th May.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 13, 2022 - 03:52 UTC