GBP deposits and withdrawals delayed for UK

Incident Report for Luno

Resolved

Deposits and withdrawals are now processing as normal and there should be no further delays.

We apologies for any inconvenience caused.
Posted Feb 03, 2025 - 18:10 UTC

Identified

We have identified an issue causing delays to EFT deposits and withdrawals which will result in longer than normal processing times.

The Instant deposit option remains unaffected.

Our team is working on this as a priority.

We apologise for any inconvenience caused.
Posted Feb 03, 2025 - 17:35 UTC