EUR price information being displayed to customers in the UK
Incident Report for Luno
Resolved
This has been fully resolved, thanks for your patience.
Posted Jan 10, 2022 - 15:07 UTC
Monitoring
A fix has gone out for this, correct currency information is being displayed. We're monitoring closely for any further potential issues.
Posted Jan 10, 2022 - 13:55 UTC
Identified
We've identified an issue affecting some customers in the UK where we're displaying EUR price information on the iOS and Android apps as well as luno.com. Buying, selling and trading remains unaffected.

Our team is working on a fix for this, apologies for any inconvenience caused.
Posted Jan 10, 2022 - 13:17 UTC