Account Verification Issue on Android
Incident Report for Luno
Resolved
The issue has been resolved. Customers should no longer experience difficulties submitting a selfie for account verification on our latest app version.

We apologise for any inconvenience caused and appreciate your patience.
Posted Jul 23, 2024 - 11:37 UTC
Update
The implemented fix has shown significant improvements in account verification on Android devices.

If you're having trouble submitting a selfie for account verification, please update your app to the latest version.
Posted Jul 22, 2024 - 09:21 UTC
Monitoring
We have successfully implemented a fix for the issue affecting customers trying to submit selfies for account verification on Android. We are monitoring the results.

Please ensure you update the app to the latest version.
Posted Jul 19, 2024 - 15:37 UTC
Identified
We are aware that some customers are encountering difficulties when attempting to submit a selfie for account verification on Android.

As a workaround customers from South Africa and Malaysia can verify their accounts using the web platform.

We are working on this as a priority.
Posted Jul 19, 2024 - 11:33 UTC