Delayed account verification
Incident Report for
Luno
Resolved
No further delays with account verification since 17:00 UTC yesterday.
Posted
Jun
06
,
2024
-
09:02
UTC
Monitoring
A fix has been implemented, we're monitoring the results.
Posted
Jun
05
,
2024
-
17:01
UTC
Identified
Customers wanting to verify their account may see a slower than normal turn around time.
Posted
Jun
05
,
2024
-
16:28
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed account verification
via . You'll receive .